LattePanda Alpha STOP WORKING

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 2
Joined: Wed Jul 29, 2020 2:09 pm

Wed Jul 29, 2020 2:34 pm

I bought a LattePanda Alpha 864s (Win10 Pro activated) on 26/03/2020. Order ID: #187950. I used it for 4 months only.

I powered up LattePanda with Type-C adapter. After switched on windows 10, suddenly it stop working. Display went off. Red and Blue LEDS went off.

I try to power up LattePanda again. There is No LED light and cannot power up anymore.

I check the power supply. There is no problem.It can work on other device.

Please Help. I need to use LattePanda urgently.

Ong Kheok Chin.

User avatar
Posts: 623
Joined: Sat Oct 13, 2018 9:16 pm

Thu Jul 30, 2020 2:31 am

I always tell people try the 4-pin DC in method first, since it is more reliable way to power the LP Alpha/Delta.

Re: USB-C powering not pworking
There are several fairlure modes and a few pilot errors simple due to overly complex of USB-C PD powering scheme.

Several questions need to be answered:
1. Have you changed anything before-n-after (formerly working, now it is not)?
E.g., changed a USB-C cable, flipped it 180 degrees, (if using a standalone USB-C power supply with a separate USB-C cable) have you changed the cable, change the connector attachment direction (e.g., that connector perviously connects to Power supply, now connects to LP Alpha), and
especially this one: add an in-line adapter (say an HDMI adapter in the middle), etc.

2. How you tested the USB-C power supply? Do you know USB-C PD have multiple profiles. The one it must be supported and must be in is 15V 3A profile.

3. Which USB-C power supply (the one came with the original shipment?)

Have you tried the "remove RTC battery trick" (see pinned thread.)

User avatar
Posts: 2
Joined: Wed Jul 29, 2020 2:09 pm

Thu Jul 30, 2020 10:52 am

1. I used the original USB-C power supply that came with the shipment. The cable of the power supply never twisted or flipped 180 degree. Never change the cable. Everything I used is original from the shipment.

I bought the original LattePanda streaming cable connects between my MacBook Pro USB port to LattePanda USB port to operate NoMachine software for display on my MacBook Pro.

2 I know your USB-C power supply has multiple profile output. I have tested your original power supply. It is not defective. It is still working. I try to plug into my MacPro computer, it showed charging. I plug into my Huawei phone, it showed charging.

3. I used only Original power supply from shipment.

What is "remove RTC battery trick" ? . How to test ?

User avatar
Posts: 623
Joined: Sat Oct 13, 2018 9:16 pm

Thu Jul 30, 2020 1:30 pm

Since yours does not have steady BLUE LED lit, this thread probably is not applicable to your situation:

In your case, it seems to be USB-C part of power supply section has problems.
I'd suggest either change to DC12V 4-pin connector method, or contact LP Tech Support.

Post Reply