Alpha 864 dead, no leds, not powering up, not with USB-c nor 12V

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Krzysztof
Posts: 12
Joined: Mon Jan 01, 2018 7:02 pm

Wed Mar 17, 2021 2:05 pm

Hi,

I started the new topic as I could not find one exactly mentioning the same issue (after seeing many cases of dead alpha, but most going in the direction of dead power supply).

So, I have not used my alpha for a while and as I wanted to start it I realized it is dead. The typical RED on and BLUE blinking pattern was not there. First what I checked was the power supply (the original LattePanda one). I connected a monitoring stick between the power supply and the alpha, and was able to see that the negotiations went well and the power supply supplied 15V at the input. Then I also connected another PD source (battery pack) and observed the same. Then I connected an external laboratory power supply to the 12V input, because I thought that maybe the PD chip stuck and connecting the 12V will unblock it. I realized that connecting the USB-C PD power supply caused the 12V source to be disconnected (I have seen it based on the current drawn from each source).

I tried to do hard reset (reset and power SW pressed applying power and releasing after 20 seconds or more, waiting a minute or more and then once again) and it did not help.

Any ideas? Is the board really and definitely bricked?

regards,
Krzysztof

User avatar
LattePanda
Site Admin
Posts: 2768
Joined: Wed Jan 20, 2016 9:09 am

Thu Mar 18, 2021 2:42 am

hello, pls send you order ID and contact techsupport@lattepanda.com for help.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
Krzysztof
Posts: 12
Joined: Mon Jan 01, 2018 7:02 pm

Thu Mar 18, 2021 6:36 pm

Hi
It was a time ago. I was backer #46 on kickstarter..
Regards
Krzysztof

Post Reply