No LED on Lattepanda Alpha

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
cow_killer
Posts: 3
Joined: Thu Mar 25, 2021 1:52 pm
Contact:

Sun May 02, 2021 6:02 pm

Greetings. I kind of knew it was going to be a risk buying a used Alpha on eBay, but it was working great for a few weeks up until today. I'm in the middle of building a portable console with this (you can see footage here). Today, I was working on an audio solution and was wrapping some cords inside the system, when all of a sudden I heard a noise. Couldn't tell what it was.

The display cables and everything was still properly seated. But I looked on the board and discovered there was no longer any LED activity coming from the board. I connected the official adapter to the USB-C port, nothing. Changed plug outlets, nothing. Tried to do a hard reset, which I guess means holding the power button for 20 seconds. Nothing. Maybe my fingers caused some sort of shock to the board and caused it to be dead?

From the troubleshooting methods I've seen here on the forums, one member mentioned taking out the RTC battery and then putting it back in to reset BIOS settings. But nowhere could I find how to remove the battery. Any advice on how to do this? Please don't tell me I have a dead board...

User avatar
cow_killer
Posts: 3
Joined: Thu Mar 25, 2021 1:52 pm
Contact:

Mon May 03, 2021 12:34 pm

Update: I just disconnected the battery and reconnected it...all good to go now.

User avatar
LattePanda
Site Admin
Posts: 2753
Joined: Wed Jan 20, 2016 9:09 am

Fri May 07, 2021 8:58 am

Hi there
Glad to hear the board is back to work now.
According to your description, it may cause by a current surge or short circuit. Please notice the ground connection when wiring.

The RTC battery is near the USB port. Reconnect it can help the board reset the bios setting and recover from the system halted.

BTW, the model of the RTC battery is CR927
Enjoy Tinkering with LattePanda ! :lol:

Post Reply