Lattepanda Alpha 864 and Wake-On-LAN (Wake-On-WAN)

A place to talk about all the Operating Systems, Software & Hardware
Post Reply
User avatar
hydefromt70s
Posts: 3
Joined: Tue Nov 06, 2018 10:23 pm
Location: UK

Mon Feb 25, 2019 7:58 pm

Hi guys!

For some time I'm an owner of Lattepanda Alpha 864. First I did I removed windows and install Ubuntu 18.10. It's a PLEX headless server so I'm doing everything via SSH. Sometimes, in location where server is, there's a power failure and I have to go to that location and manually switch back LPA. I think I'm already tried everything to sort out Wake-On-Lan / Wake-On-Wan functionality but no succeed.

Does any one can tell me how to force LPA board to work with Wake on Wan ?

User avatar
ccs_hello
Posts: 290
Joined: Sat Oct 13, 2018 9:16 pm

Tue Feb 26, 2019 12:46 pm

Let's try basics one step at a time...

1. Put the LPA864 in "Sleep" state (S3 state) and check if WOL works.
2. (to be continued, if step 1 works)

User avatar
ccs_hello
Posts: 290
Joined: Sat Oct 13, 2018 9:16 pm

Thu Feb 28, 2019 5:17 am

Now I had some time to test out the WOL.

In Win10, I found the LAN flavor of WOL works on both Sleep (S3) and Hibernation (S4) states.

On the other hand, Hybrid-Hibernation (Windows default power-down) and full power-down (S5 will be active_LOW in this mode) will not work on WOL.
<-- this limitation is well known since Win8 era for many PCs

WOL over WAN is a bit tricky (need to get home router setting right), Google is your best friend.


The settings I have to check/change to get WOL working are:
in BIOS menu, enable WOL.
In Control Panel > Device Manager > Gigabit Ethernet (Realtek RT8111E) Properties:
in Power Management tab, check all three boxes.
In Advanced tab, DISABLE the "Turn off wake on LAN" (or something like that), and possible several settings.

BTW, I used the IOS app "RemoteBoot WOL" to test it out.

Post Reply