LattePanda Mu with Lite Carrier Board - USB/M.2/PCIe Devices Not Recognized

userHead Michael Bestic 2024-05-09 03:58:32 102 Views0 Replies

I recently (within the past week or so) purchased a LattlePanda Mu, active cooler and lite carrier board from DFRobot. I seem to have run into a few issues and was hoping you would be able to assist me with resolving them. In general, I've downloaded/installed all windows updates, updated device drivers if available, reflashed the default BIOS from the GitHub article, removed and reseated/resinstalled the mu module in the carrier board, changed to a 12V power supply with 100A and reinstalled Windows. None of these troubleshooting steps resolved any of these issues. 

The four (4) issues are listed below:

(1) USB devices are not recognized by Windows 11 by both USB 2.0 ports and one USB 3.0 port. The only port that works is the top USB 3.0 port. I tried a few different USB devices The device manager shows the following:
 

image.png
 

I have uninstalled the usb root hubs and resintalled but that did not allow the other 3.0 port to work. I also went into the BIOS to ensure USB devices were enabled and they are enabled. 

(2) I installed the CR1220 battery properly (and reinstalled to ensure that wasn't the issue) but every time I turn off the computer, unplug the power supply, wait a minute or so, plug the power supply back in, and start the computer, I get a CMOS checksum error that shows up while trying to boot. It will fail to boot, restart and will boot just fine after that.

(3) I installed an M.2 Wifi Card into the M.2 E Key slot; however, it will not show up in the device manager no matter what I do. The WiFi card does work and I confirm this by putting it into my laptop to test. It won't show up in the device manager no matter what I've tried. 

(4) I tried using an Nvidia GTX1050 graphics card in the PCIe x4 slot on the board. The PCIe slot is getting power, as the light on the carrier board is lit red by the capacitors by the slot. The GPU fan also does spin when plugged into the board, but no device is shown in windows device manager. I even tried a 12V, 135A power supply but this didn't change anything. 

I'm at a loss for what to try next as I've been troubleshooting for over 6-7 hours at this point with no success. I'm not sure if there is something wrong with the carrier board connections (there's no damage to the board I can visually see) or if I'm missing something obvious in the BIOS but any help you could provide would be much appreciated. I'm very excited to start using the board and have really enjoyed its performance thus far; however, these issues have prevented me from using it to its full capability.